Dicas, truques, tutoriais, reviews, promoções e informação

sexta-feira, 12 de agosto de 2011

Como instalar extensões antigas no Firefox 4, 5 ou posterior

Você encontrou o complemento que estava procurando. Mas quando foi instalar viu que ele é incompatível com a versão do Firefox que você está usando. Isso é ruim, não é mesmo?

No entanto, existe um método de driblar esta incompatibilidade e usar a extensão nas versões novas do Firefox. Para quem usa o Firefox 4, 5, 6, 7 ou 8 é uma mão na roda.

É o que você vai conferir agora mesmo.

Veja também:
Como instalar duas versões diferentes do Firefox no PC
Como esconder as propagandas de qualquer site com Firefox e Chrome
Copie os textos automaticamente no Firefox e Chrome

Instalando extensões obsoletas no Firefox novo


1. Clique com o botão direito sobre o botão de download da extensão e selecione Salvar link como. Salve o arquivo em seu desktop.

instalar-extensões incompativeis-no-firefox-25

2. Clique com o botão direito do mouse sobre o arquivo, selecione Renomear e altere apenas a extensão de ".xpi" para ".zip" (sem as aspas).

instalar-extensões-antigas-no-firefox-4-5-6-20

3. Dê um duplo clique no arquivo para abrir a pasta zip e extraia apenas o arquivo install.rdf. Dê um duplo clique neste arquivo e na janela que abrir escolha a opção "Selecionar um programa em uma lista de programas instalados". Quando a lista aparecer escolha o Bloco de Notas. O conteúdo do arquivo será aberto no bloco.

como-forçar-compatibilidade-das-extensões-do-firefox

instalar-extensões-incompatíveis-firefox-sem-o-Nightly-Tester-Tools

4. Procure e encontre a seguinte linha: <em:maxVersion>Nº DA VERSÃO AQUI</em:maxVersion>. Onde está "Nº DA VERSÃO AQUI" é a versão máxima que o add-on suporta.

instalar-complementos-antigos-no-firefox-5-6-7

5. Troque o valor que ali está (entre os > <) pelo valor de uma versão recente do Firefox - como a versão que você está usando ou posterior. Por exemplo: 4.0.*, 5.0.*, 8.0.*, 12.0.*. Depois salve a mudança.

instalar-complementos-antigos-incompativeis-com-o-novo-firefox

6. Arraste o arquivo install.rdf modificado de volta à pasta zip e troque pelo antigo. Agora altere novamente a extensão .zip para .xpi e salve.

7. Após isto, abra o Firefox, arraste este arquivo .xpi para uma aba do navegador e instale o complemento normalmente. Depois reinicie para concluir a instalação e pronto!

OBS: É possível que algumas extensões não funcionem adequadamente após isto. Entretanto, é um risco que você corre!

TESTE

Acesse este link, procure por uma extensão incompatível com a versão que você usa e faça o teste.

5 comentários:

  1. uhulllllllll \o/
    o baguio funfa msm man o.Ô
    demais...ate twitei no meu twitter
    vlwsss

    ResponderExcluir
  2. Valeu, ótimo tutorial.
    Todas as minhas extensões antigas funcionaram! Muito obrigado!

    ResponderExcluir
  3. Olá amigos
    Obrigado pelos comentários. Que bom que ajudou vocês.

    Abraços

    ResponderExcluir
  4. Um jeito simples de instalar extensões incompatíveis no Firefox.

    1. Na barra de endereços do Firefox , digite “about:config”( sem aspas ) e dê um Enter;

    2. Leia o alerta e clique em “Eu serei cuidadoso, prometo!”;

    3. Em um espaço em branco da página, clique com o botão direito do mouse, aponte para “Novo” e clique em “Boolean”;

    4. Na janela que deve surgir, digite “extensions.checkCompatibility.4.0”(sem aspas) e pressione “OK”;

    5. Escolha a opção “false” e clique em “OK” novamente;

    6. Reinicie o Firefox e experimente instalar aquela extensão incompatível.

    Obs: no passo 4 você deve seguir de acordo com a sua versão.

    Exs:
    firefox 4.0.1 - extensions.checkCompatibility.4.0.1
    firefox 5 - extensions.checkCompatibility.5.0
    firefox 6(beta) - extensions.checkCompatibility.6.0b
    firefox 7(aurora) - extensions.checkCompatibility.7.0a

    ResponderExcluir
  5. Man, seu tutorial é foda cara. Minhas extensões estão funcionando que é uma beleza. Valeu pela dica.

    ResponderExcluir